Security Advisory

BridgePay is committed to providing the latest security protections as quickly as possible. In alignment with this commitment, we are providing this notification regarding security vulnerabilities reported by Google, Intel and AMD affecting systems worldwide.
Microsoft released patches on January 3rd and January 9th to address the Spectre and Meltdown vulnerabilities. Almost immediately, the technical community reported system crashes and numerous instability issues from these Microsoft patches. BridgePay is continuing to evaluate these patches on test systems to avoid any instability issues on our gateway production systems. All system patches go through stringent BridgePay change control processes to ensure production operations are not affected.
At this stage, it is useful to know that this is not a remote attack; the attack software must be installed and running on the local machine to exploit the vulnerability. BridgePay has deployed additional security software to prevent unauthorized code from executing on its systems and will remain vigilant regarding security and operational commitments.
If you have questions regarding whether your local system is affected, contact your IT department.
Below are some technical links that may help with understanding these changes:

Thank you,
Gateway Support