|
All versions of BBj prior to 23.07 that integrate with Jetty are susceptible to a security vulnerability relating to file uploads. In BBj 25.10 we have further hardened the default settings to prevent unauthenticated file upload. To fully address this vulnerability, ensure you upgrade to BBj 25.10 or higher to receive the latest security fixes.
Additionally, when upgrading from a version prior to BBj 25.00, remember that any application referencing the javax.servlet package in its USE statement will need to switch the reference to jakarta.servlet. That’s to utilize the Jakarta EE10 servlet architecture, and allows everyone to upgrade code libraries that were stuck on EE8 architecture.
|