Security Notice: Action Required

SSL Certificate Expiration
PayGuardian Desktop EOL Notice

Please review this entire announcement for a complete understanding and plan of action for the SSL Certificate Expiration, and PayGuardian Desktop (versions 2.3.6 and older) End of Life Notice that may affect your end users.
SSL Certificate Expiration

BridgePay is announcing the current PayGuardian Desktop SSL certificate will expire at 7 p.m. EST on December 16th, 2022. All industry SSL certificates or "certs" now only have a one year life span and thus must be updated annually.

This SSL certificate expiration only applies to
PayGuardian Desktop 2.4.11 or older.

Users of PayGuardian Desktop 2.4.11 or older will need to update to the new SSL cert to avoid security warning pop-ups presented while trying to run a transaction. PayGuardian Desktop integrators and resellers must take action such as integration testing and end user notification to avoid processing interruptions (e.g. warning pop-ups for users).

Users of PayGuardian Desktop 2.4.12 or newer will not need to take action because the software automatically downloads the updated SSL certificate.

How do I check my PayGuardian version?
Open your PayGuardian app on your desktop (select the PayGuardian icon from your Windows task bar). In the PayGuardian app, go to Help then About to view the version.

PayGuardian Desktop users will have two paths available to address the upcoming SSL certificate expiration.

1) Upgrade to PayGuardian 2.4.12 or newer. The current available version is 2.4.14.13, which includes the latest SSL certificate and an enhancement to automatically check and download future updated SSL certs when the application is started. This is the most user-friendly option for updating these annual certs. Version 2.4.14 is available for integrators to allow for proper testing and deployment to end users. We encourage all integrators to upgrade to 2.4.14, not only for this SSL cert enhancement, but to receive the many updates available in this latest version.
If for some reason you encounter an issue with 2.4.12 or newer, please follow the instructions listed below.

2) If the integrator continues to use the existing version (2.4.11 or older), the user will need to utilize the BridgePay SSL Cert update tool, which is available for download using these instructions.

BridgePay is asking all Integrators to work towards supporting 2.4.14.13 to allow users to receive the user friendly automatic detection and installation of the annual SSL renewal.

Our Integrations and 24/7 Gateway Technical Support teams are here to help.

How do I contact the BridgePay Integrations team?
Our team can be reached by phone at 866-531-1460 option 4 or via our Integrations Support portal.

How do I contact the 24/7 Gateway Technical Support team?
The team can be reached by phone at 866-322-9894 or via email at gateway.support@bridgepaynetwork.com.
PayGuardian Desktop End of Life for Versions 2.3.6 and older

BridgePay will no longer support PayGuardian Desktop versions 2.3.6 and older effective April 30, 2023. The terminal software and EMV kernels used in these earlier PayGuardian versions are no longer compliant.

Please work to upgrade to the most current version of PayGuardian Desktop to ensure proper transaction processing with BridgePay.
Sign up today to access our Integration Support portal
Why do you need a log in to access BridgePay's Integration Support portal? This allows our team to better track and respond to the cases or questions you have entered into our system. The more information we have on your integration, the better we can assist you!
Coding to BridgePay has never been easier!
BridgePay's Developer Center offers our integrators all the tools needed for a simple development effort: SDKs, API documentation, samples galore and robust knowledge base.

Access our Developer Center 24/7/365 -- no login required!